Heat Bed Terminal Burning Fix

Description

The terminals where the hot bed wires screw / plug into the main board are known to burn or stop working. This is caused by the amount of power that passes through the terminal connectors which are not rated for this. If your hot bed stops working it is most likely this causing it. Look for burn marks on the side of the terminal connectors or loose wires. The terminal block for the hot bed power can be replace by higher current rated terminals. There are a few ways to do this (solder the wires directly to the board, use similar but higher rated terminal block, or use XT60 connectors that are rated for high current).

Hotbed Burnt Connector

Burnt Hotbed Connector

Parts Required

Procedure

  • Remove the original hot bed power connector plastic housing from the main board.
  • Rotate the lugs so they are to the board edge.

    Rotating Lugs

    Rotating Lugs

  • Tin the pins on the board and on the lugs.

    Tinning XT60

    Tinning XT60

  • Solder the lugs to the pins that are on the main board (after the old plastic housing was removed).

    XT60 Soldered to Board

    XT60 Soldered to Board

  • Cut the Ferrules off the ends of the wires and strip them back about 1/8″ and tin the ends.
  • Add heat shrink over the two wires (before you solder them onto the connector).
  • Solder the two wires onto the other half of the connector making sure you line up the red to + and black to – on the main board.
  • Slide the heat shrink over the ends of the wires and connector lugs and heat them up with a hot air gun or lighter.
  • Plug the connector onto the main board and test.

    Completed XT60 Installation

    Completed XT60 Installation

Skip to toolbar